2007-06-05

[Linux] FedoraCore 7 にアップグレードしてみるか。

Fedora Core 7 がリリースされたってことで、インストールとかして実験してみたいのですが、そんな環境が手元に無いので、今 FedoraCore 6 で利用しているシステムを Fedore Core 7 にアップグレードしているところ。 いまのところやったのはこんな内容


# FedoraCore 7 の DVD ISO image を loopback でマウント
$ sudo mount -t iso9660 -o loop Fedora-7-i386/F-7-i386-DVD.iso /mnt/hoge/
# fedora のディストリビューションのリリース情報だけアップグレード
$ cd /mnt/hoge/fedora
$ sudo rpm -Uvh fedora-release-7-3.noarch.rpm fedora-release-notes-7.0.0-1.noarch.rpm
# yum でアップグレード
$ sudo yum update

うまくいくかどうか実験中



  • mkinitrd の依存パッケージが解決できないってことだったので、i386 版の mkinitrd をアンインストールしておいた。こんな感じに
    rpm -e mkinitrd.i386
    ちなみに利用しているのは x86_64版。

  • インストールするファイルのコンフリクトが起きた模様。 これらの i386 パッケージのアンインストールを実施。

    mysql-devel.i386
    esound-0.2.36-3
    libgnome-2.16.0-4.fc6.i386
    control-center-2.16.3-11.fc6.i386
    gnome-media-2.16.1-4.fc6.i386
    evolution-data-server-1.8.3-6.fc6.i386
    evolution-2.8.3-2.fc6.i386
    nautilus-cd-burner-2.16.3-1.fc6.i386
    gtkhtml3-3.12.3-1.fc6.i386
    gnome-panel-2.16.3-2.fc6.i386
    gnome-desktop-2.16.3-1.fc6.i386
    gnome-pilot-2.0.15-1.fc6.i386
    eel2-2.16.1-1.fc6.i386
    eel2-devel-2.16.1-1.fc6.i386
    gnome-pilot-devel-2.0.15-1.fc6.i386
    gnome-desktop-devel-2.16.3-1.fc6.i386
    gnome-utils-2.16.0-1.fc6.i386
    gnome-panel-devel-2.16.3-2.fc6.i386
    evolution-data-server-devel-1.8.3-6.fc6.i386
    libbonoboui-2.16.0-1.fc6.i386
    libgnomeui-2.16.0-4.fc6.i386
    libgnome-devel-2.16.0-4.fc6.i386
    libbonoboui-devel-2.16.0-1.fc6.i386
    libgnome-java-2.12.4-3.fc6.i386
    libgnomeui-devel-2.16.0-4.fc6.i386
    libglade-java-2.12.5-3.fc6.i386
    gdb.i386


  • アップグレードするパッケージは 2316個だってさ。

0 件のコメント:

コメントを投稿